[Nvda-dev] Field-related quick navigation keys do not work for Internet Explorer

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[Nvda-dev] Field-related quick navigation keys do not work for Internet Explorer

Victor Tsaran
Hello guys,
I just noticed that none of the quicknav keys that allow the user to reach buttons, edit fields, etc work when you are browsing with Internet Explorer. I did not want to bug it up just yet but to ensure that this is a known bug already.
Can someone please confirm?

Thanks,
Vic



--- Victor Tsaran on iTunes at http://ax.itunes.apple.com/us/artist/victor-tsaran/id344507896 **


Reply | Threaded
Open this post in threaded view
|

Re: [Nvda-dev] Field-related quick navigation keys do not work for Internet Explorer

Victor Tsaran
Hello all,
I have to investigate this further. One time the quicknav keystrokes for form fields work and other time they don't. I think I am a little confused now.
Thanks,
Vic



** Get my latest album on iTunes at http://ax.itunes.apple.com/us/artist/victor-tsaran/id344507896 **


--- On Mon, 12/21/09, Victor Tsaran <[hidden email]> wrote:

> From: Victor Tsaran <[hidden email]>
> Subject: [Nvda-dev] Field-related quick navigation keys do not work for Internet Explorer
> To: "Development for NonVisual Desktop Access" <[hidden email]>
> Date: Monday, December 21, 2009, 12:54 AM
> Hello guys,
> I just noticed that none of the quicknav keys that allow
> the user to reach buttons, edit fields, etc work when you
> are browsing with Internet Explorer. I did not want to bug
> it up just yet but to ensure that this is a known bug
> already.
> Can someone please confirm?
>
> Thanks,
> Vic
>
>
>
> --- Victor Tsaran on iTunes at http://ax.itunes.apple.com/us/artist/victor-tsaran/id344507896
> **
>
> _______________________________________________
> Nvda-dev mailing list
> [hidden email]
> http://lists.nvaccess.org/listinfo/nvda-dev
>


Reply | Threaded
Open this post in threaded view
|

Re: [Nvda-dev] Field-related quick navigation keys do not work forInternet Explorer

Brian Gaff Lineone downstairs
Which version of IE and other details might be handy. If we have a known
page and set up where its predictable  it might be nice.
Brian

[hidden email]
Brian Gaff's other account.

----- Original Message -----
From: "Victor Tsaran" <[hidden email]>
To: " a free and open source screen reader for Microsoft WindowsNews
anddiscussion for NVDA (NonVisual Desktop Access)"
<[hidden email]>
Sent: Monday, December 21, 2009 9:12 AM
Subject: Re: [Nvda-dev] Field-related quick navigation keys do not work
forInternet Explorer


> Hello all,
> I have to investigate this further. One time the quicknav keystrokes for
> form fields work and other time they don't. I think I am a little confused
> now.
> Thanks,
> Vic
>
>
>
> ** Get my latest album on iTunes at
> http://ax.itunes.apple.com/us/artist/victor-tsaran/id344507896 **
>
>
> --- On Mon, 12/21/09, Victor Tsaran <[hidden email]> wrote:
>
>> From: Victor Tsaran <[hidden email]>
>> Subject: [Nvda-dev] Field-related quick navigation keys do not work for
>> Internet Explorer
>> To: "Development for NonVisual Desktop Access"
>> <[hidden email]>
>> Date: Monday, December 21, 2009, 12:54 AM
>> Hello guys,
>> I just noticed that none of the quicknav keys that allow
>> the user to reach buttons, edit fields, etc work when you
>> are browsing with Internet Explorer. I did not want to bug
>> it up just yet but to ensure that this is a known bug
>> already.
>> Can someone please confirm?
>>
>> Thanks,
>> Vic
>>
>>
>>
>> --- Victor Tsaran on iTunes at
>> http://ax.itunes.apple.com/us/artist/victor-tsaran/id344507896
>> **
>>
>> _______________________________________________
>> Nvda-dev mailing list
>> [hidden email]
>> http://lists.nvaccess.org/listinfo/nvda-dev
>>
>
> _______________________________________________
> Nvda-dev mailing list
> [hidden email]
> http://lists.nvaccess.org/listinfo/nvda-dev


--------------------------------------------------------------------------------



No virus found in this incoming message.
Checked by AVG - www.avg.com
Version: 9.0.717 / Virus Database: 270.14.116/2578 - Release Date: 12/20/09
19:35:00




Reply | Threaded
Open this post in threaded view
|

Re: [Nvda-dev] Field-related quick navigation keys do not work forInternet Explorer

Victor Tsaran
Hi Brian,
I am talking about IE8 specifically and I am seeing this behavior inside the Yahoo! Classic Mail.
Generally, it seems that this happens when the virtual buffer did not refresh as a result of dynamic chages on the page. Once the ubffer is forcefully refreshed with INSERT+F5, then nav keys seem to work again.
Thoughts?
V


** Get my latest album on iTunes at http://ax.itunes.apple.com/us/artist/victor-tsaran/id344507896 **


--- On Mon, 12/21/09, Brian Gaff Lineone downstairs <[hidden email]> wrote:

> From: Brian Gaff Lineone downstairs <[hidden email]>
> Subject: Re: [Nvda-dev] Field-related quick navigation keys do not work forInternet Explorer
> To: "News and discussion for NVDA (NonVisual Desktop Access), a free and open source screen reader for Microsoft Windows" <[hidden email]>
> Date: Monday, December 21, 2009, 2:15 AM
> Which version of IE and other details
> might be handy. If we have a known page and set up where its
> predictable  it might be nice.
> Brian
>
> [hidden email]
> Brian Gaff's other account.
>
> ----- Original Message ----- From: "Victor Tsaran" <[hidden email]>
> To: " a free and open source screen reader for Microsoft
> WindowsNews anddiscussion for NVDA (NonVisual Desktop
> Access)" <[hidden email]>
> Sent: Monday, December 21, 2009 9:12 AM
> Subject: Re: [Nvda-dev] Field-related quick navigation keys
> do not work forInternet Explorer
>
>
> > Hello all,
> > I have to investigate this further. One time the
> quicknav keystrokes for form fields work and other time they
> don't. I think I am a little confused now.
> > Thanks,
> > Vic
> >
> >
> >
> > ** Get my latest album on iTunes at http://ax.itunes.apple.com/us/artist/victor-tsaran/id344507896
> **
> >
> >
> > --- On Mon, 12/21/09, Victor Tsaran <[hidden email]>
> wrote:
> >
> >> From: Victor Tsaran <[hidden email]>
> >> Subject: [Nvda-dev] Field-related quick navigation
> keys do not work for Internet Explorer
> >> To: "Development for NonVisual Desktop Access"
> <[hidden email]>
> >> Date: Monday, December 21, 2009, 12:54 AM
> >> Hello guys,
> >> I just noticed that none of the quicknav keys that
> allow
> >> the user to reach buttons, edit fields, etc work
> when you
> >> are browsing with Internet Explorer. I did not
> want to bug
> >> it up just yet but to ensure that this is a known
> bug
> >> already.
> >> Can someone please confirm?
> >>
> >> Thanks,
> >> Vic
> >>
> >>
> >>
> >> --- Victor Tsaran on iTunes at http://ax.itunes.apple.com/us/artist/victor-tsaran/id344507896
> >> **
> >>
> >> _______________________________________________
> >> Nvda-dev mailing list
> >> [hidden email]
> >> http://lists.nvaccess.org/listinfo/nvda-dev
> >>
> >
> > _______________________________________________
> > Nvda-dev mailing list
> > [hidden email]
> > http://lists.nvaccess.org/listinfo/nvda-dev
>
>
> --------------------------------------------------------------------------------
>
>
>
> No virus found in this incoming message.
> Checked by AVG - www.avg.com
> Version: 9.0.717 / Virus Database: 270.14.116/2578 -
> Release Date: 12/20/09 19:35:00
>
>
>
> _______________________________________________
> Nvda-dev mailing list
> [hidden email]
> http://lists.nvaccess.org/listinfo/nvda-dev
>


Reply | Threaded
Open this post in threaded view
|

Re: [Nvda-dev] Field-related quick navigation keys do not work forInternet Explorer

Michael Curran-3
Hi Vic,

Before you refresh the buffer, is it possible for you to arrow to the
fields you are trying to jump to?
i.e. are they clearly in the buffer at that point in time?

If they are not, then we're simply not being told by IE that a
particular part of the page has updated. If they are, then again we
havn't been told  something has been updated, though its only a small
change such as a state or attribute change.

Mick




On 22/12/2009 7:18 PM, Victor Tsaran wrote:

> Hi Brian,
> I am talking about IE8 specifically and I am seeing this behavior inside the Yahoo! Classic Mail.
> Generally, it seems that this happens when the virtual buffer did not refresh as a result of dynamic chages on the page. Once the ubffer is forcefully refreshed with INSERT+F5, then nav keys seem to work again.
> Thoughts?
> V
>
>
> ** Get my latest album on iTunes at http://ax.itunes.apple.com/us/artist/victor-tsaran/id344507896 **
>
>
> --- On Mon, 12/21/09, Brian Gaff Lineone downstairs<[hidden email]>  wrote:
>
>> From: Brian Gaff Lineone downstairs<[hidden email]>
>> Subject: Re: [Nvda-dev] Field-related quick navigation keys do not work forInternet Explorer
>> To: "News and discussion for NVDA (NonVisual Desktop Access), a free and open source screen reader for Microsoft Windows"<[hidden email]>
>> Date: Monday, December 21, 2009, 2:15 AM
>> Which version of IE and other details
>> might be handy. If we have a known page and set up where its
>> predictable  it might be nice.
>> Brian
>>
>> [hidden email]
>> Brian Gaff's other account.
>>
>> ----- Original Message ----- From: "Victor Tsaran"<[hidden email]>
>> To: " a free and open source screen reader for Microsoft
>> WindowsNews anddiscussion for NVDA (NonVisual Desktop
>> Access)"<[hidden email]>
>> Sent: Monday, December 21, 2009 9:12 AM
>> Subject: Re: [Nvda-dev] Field-related quick navigation keys
>> do not work forInternet Explorer
>>
>>
>>> Hello all,
>>> I have to investigate this further. One time the
>> quicknav keystrokes for form fields work and other time they
>> don't. I think I am a little confused now.
>>> Thanks,
>>> Vic
>>>
>>>
>>>
>>> ** Get my latest album on iTunes at http://ax.itunes.apple.com/us/artist/victor-tsaran/id344507896
>> **
>>>
>>>
>>> --- On Mon, 12/21/09, Victor Tsaran<[hidden email]>
>> wrote:
>>>
>>>> From: Victor Tsaran<[hidden email]>
>>>> Subject: [Nvda-dev] Field-related quick navigation
>> keys do not work for Internet Explorer
>>>> To: "Development for NonVisual Desktop Access"
>> <[hidden email]>
>>>> Date: Monday, December 21, 2009, 12:54 AM
>>>> Hello guys,
>>>> I just noticed that none of the quicknav keys that
>> allow
>>>> the user to reach buttons, edit fields, etc work
>> when you
>>>> are browsing with Internet Explorer. I did not
>> want to bug
>>>> it up just yet but to ensure that this is a known
>> bug
>>>> already.
>>>> Can someone please confirm?
>>>>
>>>> Thanks,
>>>> Vic
>>>>
>>>>
>>>>
>>>> --- Victor Tsaran on iTunes at http://ax.itunes.apple.com/us/artist/victor-tsaran/id344507896
>>>> **
>>>>
>>>> _______________________________________________
>>>> Nvda-dev mailing list
>>>> [hidden email]
>>>> http://lists.nvaccess.org/listinfo/nvda-dev
>>>>
>>>
>>> _______________________________________________
>>> Nvda-dev mailing list
>>> [hidden email]
>>> http://lists.nvaccess.org/listinfo/nvda-dev
>>
>>
>> --------------------------------------------------------------------------------
>>
>>
>>
>> No virus found in this incoming message.
>> Checked by AVG - www.avg.com
>> Version: 9.0.717 / Virus Database: 270.14.116/2578 -
>> Release Date: 12/20/09 19:35:00
>>
>>
>>
>> _______________________________________________
>> Nvda-dev mailing list
>> [hidden email]
>> http://lists.nvaccess.org/listinfo/nvda-dev
>>
>
> _______________________________________________
> Nvda-dev mailing list
> [hidden email]
> http://lists.nvaccess.org/listinfo/nvda-dev


--
Michael Curran
President, NV Access Inc
Email: [hidden email]
Website: www.nvaccess.org
ABN 61773362390.


Reply | Threaded
Open this post in threaded view
|

[Nvda-dev] Problems choosing languages on r3444

mk360
    Hi,

    The current snaphsot version has problems selecting spanish language. By
default, NVDA start in portuguese language, but my system is in spanish (the
option selected is user default) and if I try to change it to spanish
manually nothing happens and NVDA continues in portuguese.

    Originally, other spanish user tell me about it, and I updated my NVDA
version to test.

    Regards,
mk.



Reply | Threaded
Open this post in threaded view
|

Re: [Nvda-dev] Field-related quick navigation keys do not work forInternet Explorer

Roopakshi Pathania
In reply to this post by Victor Tsaran

Hi Victor,

Is the problem still there?
Most of the time I don't encounter this issue, perhaps because I disable the automatic page updates. Yahoo gives me this message.


"If you are using a screen reader and having problems using Mail, it might help to disable automatic page updates. Please note, this will also disable chat and text messaging within Yahoo! Mail. You can toggle automatic updates on and off using the link below."

Regards

“The problem isn't that people don't understand how good things are. It's that they know, from personal experience, that things really aren't that good.”
~ Paul Krugman


--- On Tue, 12/22/09, Victor Tsaran <[hidden email]> wrote:

> From: Victor Tsaran <[hidden email]>
> Subject: Re: [Nvda-dev] Field-related quick navigation keys do not work forInternet Explorer
> To: "Brian Gaff Lineone downstairs" <[hidden email]>, " a free and open source screen reader for Microsoft WindowsNews and discussion for NVDA (NonVisual Desktop Access)" <[hidden email]>
> Date: Tuesday, December 22, 2009, 1:48 PM
> Hi Brian,
> I am talking about IE8 specifically and I am seeing this
> behavior inside the Yahoo! Classic Mail.
> Generally, it seems that this happens when the virtual
> buffer did not refresh as a result of dynamic chages on the
> page. Once the ubffer is forcefully refreshed with
> INSERT+F5, then nav keys seem to work again.
> Thoughts?
> V
>
>
> ** Get my latest album on iTunes at http://ax.itunes.apple.com/us/artist/victor-tsaran/id344507896
> **
>
>
> --- On Mon, 12/21/09, Brian Gaff Lineone downstairs <[hidden email]>
> wrote:
>
> > From: Brian Gaff Lineone downstairs <[hidden email]>
> > Subject: Re: [Nvda-dev] Field-related quick navigation
> keys do not work forInternet Explorer
> > To: "News and discussion for NVDA (NonVisual Desktop
> Access), a free and open source screen reader for Microsoft
> Windows" <[hidden email]>
> > Date: Monday, December 21, 2009, 2:15 AM
> > Which version of IE and other details
> > might be handy. If we have a known page and set up
> where its
> > predictable  it might be nice.
> > Brian
> >
> > [hidden email]
> > Brian Gaff's other account.
> >
> > ----- Original Message ----- From: "Victor Tsaran"
> <[hidden email]>
> > To: " a free and open source screen reader for
> Microsoft
> > WindowsNews anddiscussion for NVDA (NonVisual Desktop
> > Access)" <[hidden email]>
> > Sent: Monday, December 21, 2009 9:12 AM
> > Subject: Re: [Nvda-dev] Field-related quick navigation
> keys
> > do not work forInternet Explorer
> >
> >
> > > Hello all,
> > > I have to investigate this further. One time the
> > quicknav keystrokes for form fields work and other
> time they
> > don't. I think I am a little confused now.
> > > Thanks,
> > > Vic
> > >
> > >
> > >
> > > ** Get my latest album on iTunes at http://ax.itunes.apple.com/us/artist/victor-tsaran/id344507896
> > **
> > >
> > >
> > > --- On Mon, 12/21/09, Victor Tsaran <[hidden email]>
> > wrote:
> > >
> > >> From: Victor Tsaran <[hidden email]>
> > >> Subject: [Nvda-dev] Field-related quick
> navigation
> > keys do not work for Internet Explorer
> > >> To: "Development for NonVisual Desktop
> Access"
> > <[hidden email]>
> > >> Date: Monday, December 21, 2009, 12:54 AM
> > >> Hello guys,
> > >> I just noticed that none of the quicknav keys
> that
> > allow
> > >> the user to reach buttons, edit fields, etc
> work
> > when you
> > >> are browsing with Internet Explorer. I did
> not
> > want to bug
> > >> it up just yet but to ensure that this is a
> known
> > bug
> > >> already.
> > >> Can someone please confirm?
> > >>
> > >> Thanks,
> > >> Vic
> > >>
> > >>
> > >>
> > >> --- Victor Tsaran on iTunes at http://ax.itunes.apple.com/us/artist/victor-tsaran/id344507896
> > >> **
> > >>
> > >>
> _______________________________________________
> > >> Nvda-dev mailing list
> > >> [hidden email]
> > >> http://lists.nvaccess.org/listinfo/nvda-dev
> > >>
> > >
> > > _______________________________________________
> > > Nvda-dev mailing list
> > > [hidden email]
> > > http://lists.nvaccess.org/listinfo/nvda-dev
> >
> >
> >
> --------------------------------------------------------------------------------
> >
> >
> >
> > No virus found in this incoming message.
> > Checked by AVG - www.avg.com
> > Version: 9.0.717 / Virus Database: 270.14.116/2578 -
> > Release Date: 12/20/09 19:35:00
> >
> >
> >
> > _______________________________________________
> > Nvda-dev mailing list
> > [hidden email]
> > http://lists.nvaccess.org/listinfo/nvda-dev
> >
>
> _______________________________________________
> Nvda-dev mailing list
> [hidden email]
> http://lists.nvaccess.org/listinfo/nvda-dev
>